The forum

Team Fortress 2 POL Installation Error

Ubuntu 12.04 - Unity - Wine 1

Author Replies
Crayboff Wednesday 25 July 2012 at 4:51

I first installed Steam via POL without changing any sort of settings at all. Steam works perfectly fine. I then installed TF2 via Steam, the installation went well (when attempting to launch from Steam, the bald head logo shows, music plays, and it gets stuck on a black screen). I attempted to install TF2 via POL, however I recieved the following error:

Error: Binary not found: steam.exe
Have you installed the program to the default location?

I then clicked Next twice (apparently clicking "Next" the first time either didn't register, or it just brought me to the same error). This brought me to another screen told me to make sure thatthe Steam interface was completely closed and not to click Play when the Steam install was finished. I clicked Next and recieved this error:

File not found.

Clicking OK to this message then gave me:

Error: Wine seems to have crashed
If your program is running, just ignore this message

And then I was prompted to send a  bug report. So I guess my question is, at risk of sounding like a complete newbie, what exactly do I have to do to get TF2 working?

Wine Info:
I have Wine versions 1.5.9 and 1.4.1 registered as installed in POL (the x86 wine versions).

Computer info: (via Sysinfo)
Release: Ubuntu 12.04 (precise)
Kernel: 3.2.0-27-generic (#43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012)
OS Type: Linux
GCC version: 4.6 (x86_64-linux-gnu)
Xorg version: 1.11.3 (16 July 2012 08:06:31PM)

Vendor: GenuineIntel
CPUs: 4
Model name: Intel(R) Core(TM) i5 CPU   M460 @ 2.53 GHz
Frequency: 2534.000 MHz
L2 cache: 3072 KB
Bogomips: 5231.20
Numbering: family(6) model(37) stepping(5)

Graphic Card
VGA compatible controller
Intel Corporation Core Processor Integrated Graphics Controller (rev 18) (prog-if 00 [VGA controller])

Tell me if there is any other info you need.

Edited by Crayboff

dracul104 Tuesday 31 July 2012 at 23:45

I have the same Ubuntu OS version and had this problem as well, so I'm guessing it's specific to this OS. I got it working by copying the Steam folder from 'Home\\.PlayOnLinux\\wineprefix\\Steam\\drive_c\\Program Files' (the .PlayOnLinux folder is hidden, so you have to enable the show hidden files option in the explorer) and copying this to the 'Home\\.PlayOnLinux\\wineprefix\\TF2\\drive_c\\Program Files'. Then I ran the Team Fortress 2 installer again, and everything worked great. Hope this works for you.